Posted by on April 3, 2015

I finally decided that this easter weekend was going to be the time to update the lab to vSphere 6.0, which meant that some messing around was going to be required due to the Gigabyte Brix using unsupported network adapters.

Hardware overview (2x):

Gigabyte BRIX i5-3337U CPU @ 1.80 Ghz (Turbo upto 2.7Ghz) 2 cores and hyper threading.

16Gb Ram and a 256Gb SSD.

A WD NFS data store (4Tb) for large slow storage..

IMG_4699

 

 

 

 

 

 

 

Updating

Ensure the host is in maintenance mode then remove the Cisco Nexus 1000v as this isn’t supported by 6.0, which whilst annoying apparently support will be appearing in the future.

Stop the Nexus 1000v services:

~ # vem stop
stopDpa
VEM SwISCSI PID is
Warn: DPA running host/vim/vimuser/cisco/vem/vemdpa.34816
Warn: DPA running host/vim/vimuser/cisco/vem/vemdpa.34816
watchdog-vemdpa: Terminating watchdog process with PID 34791

Remove the software (vib):

~ # esxcli software vib remove -n cisco-vem-v160-esx
Removal Result
Message: Operation finished successfully.
Reboot Required: false
VIBs Installed:
VIBs Removed: Cisco_bootbank_cisco-vem-v160-esx_4.2.1.2.2.1.0-3.2.1
VIBs Skipped:

Follow the steps outlined here for the Offline bundle:

http://www.vladan.fr/patch-esxi-5-5-to-esxi-6-0/ (no point writing out the same thing outlined here..)

This will take a little while as all of the various packages are installed and the relevant bootbanks are updated.

~ # esxcli software vib update -d /vmfs/volumes/products/Operating\ Systems/VMware/6.0/VMware-ESXi-6.0.0-2494585-depot.zip
Installation Result
Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
Reboot Required: true
VIBs Installed:

Download the realtek drives from vibsdepot (vibsdepot.v-front.de):

~ # wget http://vibsdepot.v-front.de/depot/bundles/net55-r8168-8.039.01-napi-offline_bundle.zip
Connecting to vibsdepot.v-front.de (144.76.26.125:80)
net55-r8168-8.039.01 100% |************************************| 1052k 0:00:00 ETA

Set the software acceptance level so that the drivers/vibs can be installed:

esxcli software acceptance set --level=CommunitySupported
Host acceptance level changed to 'CommunitySupported'.

Install the drivers:

~ # esxcli software vib install -d /net55-r8168-8.039.01-napi-offline_bundle.zip
Installation Result
Message: The update completed successfully, but the system needs to be rebooted for the changes to be effective.
Reboot Required: true
VIBs Installed: Realtek_bootbank_net55-r8168_8.039.01-napi
VIBs Removed:
VIBs Skipped:

and Reboot 🙂

vSphere 6

Troubleshooting

To repair the networking the first time I had to remove the USB Boot key and try and examine it through VMware Fusion, unfortunately the Fusion BIOS doesn’t support booting from USB. Luckily the PLOB Boot utility does (http://www.plop.at/en/bootmanager/download.html), so download this and place the ISO as your CD-ROM boot device and from here you can then boot over to USB.

 

Posted in: Computers

Comments

Be the first to comment.

Leave a Reply


You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

*